To make sure your GPU is compatible with KeyShot, its drivers need to be compatible with OpenGL 2.0 or higher. Since the Windows Remote Desktop application is only compatible with OpenGL 1.1.0, KeyShot will not start and you will get an error message stating that your graphics card isn't compatible with OpenGL 2.0. 

To get around this issue, you can use another remote desktop application such as TeamViewer, OpenVNC, and others.