Start a new topic

Move tool issue

Hey


After updating to keyshot 10 something strange has happen to my move tool. When zooming close to an object to precision move the object, the move tool arrows will not highlight and allow grabbing. When zooming out, the arrows again highlight when hoovering over and I'm able to move the object using the manual arrows. The same applies to rotating and scaling. I know I can use the numeric controls, but this takes too long. Any ideas?


Leo


Hello Leo,

Thank you for contacting Luxion.
Its a typical IT answer and I apologize in advance, but have you restarted your computer to see if that solves the issue?
The move tool can be affected by the mouse sensitivity and the computer's display settings.
Check your computer's screen resolution and if the scale and layout are set to 125% instead of the preferred 150% and that the resolution.

Failing this, please send us your computer's specs and if possible, a copy of your DxDiag file.

How to create a DxDiag log
  1. Press the Windows Key + R
  2. Enter "DxDiag" and run the command
  3. Press 'Save all information' and save the file in an easy to find location

 

Referencing your Ticket ID#:24199

 

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist
Hello Leo,

Thank you for contacting Luxion.
It looks as if you are using slightly older GPU drivers.
Updating these may solve the issue.

Let me know if this helps.

Referencing your Ticket ID#:24199

 

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist
Hello Leo,

Thank you for contacting Luxion.
Lets try one more thing...
Please try a fresh install using the full installer:

How to perform a fresh install:

  1. Uninstall KeyShot
  2. Make sure to delete the KeyShot resources folder
    • note: move it to the desktop if you wish to back up your resources
    • Windows Default:
      • C:\Users\UserName\Documents\KeyShot or
      • C:\Users\Public\Documents\KeyShot
      • Delete C:\ProgramData\Luxion\KeyShot 9 folder
      • Delete C:\Users\%username%\AppData\Local\Luxion\KeyShot 9 folder
    • Mac Default:
      • /Library/Application Support/KeyShot
  3. Download and Re-install KeyShot using the links below.
    For this step, you’ll need the full installer(not the update installer).
    • You can find the newest version of KeyShot here.
    • You can find older versions of KeyShot here.
  4. Go through the registration wizard, enter your license information, and KeyShot should be up and running.
Please let me know how this works for you.

Referencing your Ticket ID#:24199

 

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

Hey dude. 


Yes, this is definitely an issue. I don't understand why Keyshot just keeps telling us to re-install the software when they don't even seem willing to look into the problem. There is obviously a problem with the software, not the machine or settings.


I've experienced the same bug many times. It appears suddenly and makes the move tool useless. The handles, both translate, scale, and rotate don't highlight when hovered, and won't respond to clicking.


Solution (temporary): What works for me is to try and zoom out a bit. Might be an issue with the camera and key shot somehow. Try marking and moving other objects, then go back to the object that has issues, and zoom out a bit with the camera. That's the only thing that works for me.


It only affects some objects in my Keyshot-file, and not always. But a restart doesn't help the issue, and when the issues appear then it seems to get stuck to that particular object. I suspect, as I said, that there is something wrong with the coding of the camera and the move tool.


Let me know if this works out for you.

Hello Leo,

Thank you for contacting Luxion.

From what you've mentioned it happens frequently and suddenly, but not every time.
When you do experience this issue, what is your camera's perspective? You will see this on the top toolbar.
What is your camera's settings? Position and orientation, lens settings, etc.

When is this generally triggered? For example, after importing another model to the scene?

What CAD software are using when the issue most commonly occurs?


Referencing your Ticket ID#:24199


Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

 Hello Leo and all,


Relatively new Keyshot user here and a few days ago I came across this exact scenario in Keyshot, where at certain zoom levels (usually in close to do detail moves), the move arrows would stop working and I couldn't even type in the translation values, as all it would do it scroll the camera around. After searching and finding this post and a few others, I realized I wasn't the only one to have this issue. I didn't find an answer as to why it was happening, but I found a very usable workaround that allowed me to zoom in close to perform detailed, precision moving of parts. What I did was go into the properties of the "Free camera" and changed the "Field of view" value and I was able to get in much closer and still retain the use of the move arrows.
Additionally what I did was create one camera, which I called my "Detail work", left it unlocked and changed the FOV on that one and put the FOV back to default on the "Free camera", this way when I know I want to do more detailed work, I switch to that camera.
I realize this thread is 5 months old now, but I hope my workaround helps.

Thanks,


Stefano


Hello Stefano,


Thank you for this information.

Can you provide us with a sample file where you experience this issue and your work-around works to solve it?


To save a ksp file:

  1. Open your scene.
  2. Go to File > Save Package.
  3. Name your file.
  4. Include Ticket number.


You may send it securely via our WeTransfer



Best Regards,


Erik Williams

Customer Support Specialist

Just adding onto this Ticket that I have had this issue now several times as well now. There is no clear solution yet to this issue. Have tried all of the above and will keep an eye on this for if there is to be a patch or fix in the future. 


Thanks,

Allon 

Login or Signup to post a comment