Start a new topic
Answered

Multi GPU rendering on AWS

Hi. Can someone tell me how to run Keyshot with NVLink enabled? I've  AWS instance with 4 Nvidia V100 GPUs, each with 16GB memory, running in TCC mode. But I can't open Keyshot due to OpenGL not being supported in TCC mode( which is required for NVLink to work) . When I switch to WDDM in Nvidia-smi, I have all 4 cards in Keyshot but the total memory is only 16GB. I'm getting confused here. Any help would be much appreciate.  


Best Answer
Hello Jedrzej,

Thank you for contacting Luxion.
KeyShot only uses 1 graphics card for GPU rendering and cannot be split up at this time.
This is something we have spoken a far bit about and are planning if and how to add this to the platform. You may be seeing only 16GB or memory because your primary graphics card is not the best one on your computer.
If you have one graphics card that you would prefer to use over the others, you can set the preferred card using the steps below.

How to set the Nvidia Graphics-card as preferred GPU
1. Open the Nvidia control panel.
2. Go to Manage 3D settings.
3. Go to the Program Settings.
4. Select KeyShot from the Drop-down.
5. If it is not available add the KeyShot.exe manually by browsing to it below.
  • C:\Program Files\KeyShot #\bin\keyshot.exe
  • %USERPROFILE%\AppData\Local\ in the KeyShot #\bin\keyshot.exe
6. Select your Nvidia graphics card under preferred graphics processor.
7. Click Apply and restart KeyShot.

I hope this answered your question. If I misunderstood, or if there is anything else I can help you with please let me know.

Referencing your Ticket ID#:9571

 

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist
1 Comment

Answer
Hello Jedrzej,

Thank you for contacting Luxion.
KeyShot only uses 1 graphics card for GPU rendering and cannot be split up at this time.
This is something we have spoken a far bit about and are planning if and how to add this to the platform. You may be seeing only 16GB or memory because your primary graphics card is not the best one on your computer.
If you have one graphics card that you would prefer to use over the others, you can set the preferred card using the steps below.

How to set the Nvidia Graphics-card as preferred GPU
1. Open the Nvidia control panel.
2. Go to Manage 3D settings.
3. Go to the Program Settings.
4. Select KeyShot from the Drop-down.
5. If it is not available add the KeyShot.exe manually by browsing to it below.
  • C:\Program Files\KeyShot #\bin\keyshot.exe
  • %USERPROFILE%\AppData\Local\ in the KeyShot #\bin\keyshot.exe
6. Select your Nvidia graphics card under preferred graphics processor.
7. Click Apply and restart KeyShot.

I hope this answered your question. If I misunderstood, or if there is anything else I can help you with please let me know.

Referencing your Ticket ID#:9571

 

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist
Login or Signup to post a comment