Start a new topic
Answered

keyshot9 is slower than keyshot8?

hello,

I was upgraded to keyshot9.

However, it looks like slower than keyshot8..


In same scene, the preview window's FPS is

keyshot9: under 100

keyshot8: 300-200


https://youtu.be/QqaW-Lu33ck


MyEnvironment

CPU:Corei9 9900k

M/B Z390

RAM 32GB

OS: Windows10 home


Best Answer
Hello patisa,

Thank you for contacting Luxion.
Due to to the add on of GPU rendering and some of the advanced materials there will be a slight difference in how your PC performs.
Here are a few things that you can try to speed up the real time render:

How to Improve Real-Time Rendering Speed:

1. Ensure that KeyShot is using all CPU cores available.
Go to to the top ribbon menu and at the top-right corner, you will find the CPU Usage drop-down. Set it to "All Cores".

2. Go into Performance Mode.
Performance Mode turns off certain scene lighting settings (e.g. ground shadows, global illumination, etc) to improve real-time res-up/frame rate. You may use the Alt+P to toggle performance mode on/off.

3. Enable Fast Real-time Updates.(KeyShot 7 and older only)
Go to Edit (PC) or KeyShot (Mac) -> Preferences -> Advanced. Click Save Changes to save your changes in Preferences.

4. Set Disable outline for large models to "Auto".
Go to Preferences -> Interface. Click "Save Changes". This will turn off the orange outlines around models if the model is very large (in number of triangles/polys).

5. Disable Import NURBS Data when importing your CAD data.
Click Import, browse to your model and Open. Go to Geometry inside the Import window and disable Import NURBS Data.

6. Work on a few parts at a time.
Hiding parts and showing only the ones you are currently working on helps improve performance.

7. Decrease your real-time view's resolution.
You may set the real-time resolution from within the Project window's Image tab. You may also drag a corner on the real-time window.

Let me know if this helps your slowing issue.


Referencing your Ticket ID#:9442

Thanks,

Justin Adams
Support manager
Luxion Inc
15143 Woodlawn Ave
Tustin, CA 92780
Phone: (949) 274-8871
Fax: (949) 266-9523
http://www.keyshot.com
 


1 Comment

Answer
Hello patisa,

Thank you for contacting Luxion.
Due to to the add on of GPU rendering and some of the advanced materials there will be a slight difference in how your PC performs.
Here are a few things that you can try to speed up the real time render:

How to Improve Real-Time Rendering Speed:

1. Ensure that KeyShot is using all CPU cores available.
Go to to the top ribbon menu and at the top-right corner, you will find the CPU Usage drop-down. Set it to "All Cores".

2. Go into Performance Mode.
Performance Mode turns off certain scene lighting settings (e.g. ground shadows, global illumination, etc) to improve real-time res-up/frame rate. You may use the Alt+P to toggle performance mode on/off.

3. Enable Fast Real-time Updates.(KeyShot 7 and older only)
Go to Edit (PC) or KeyShot (Mac) -> Preferences -> Advanced. Click Save Changes to save your changes in Preferences.

4. Set Disable outline for large models to "Auto".
Go to Preferences -> Interface. Click "Save Changes". This will turn off the orange outlines around models if the model is very large (in number of triangles/polys).

5. Disable Import NURBS Data when importing your CAD data.
Click Import, browse to your model and Open. Go to Geometry inside the Import window and disable Import NURBS Data.

6. Work on a few parts at a time.
Hiding parts and showing only the ones you are currently working on helps improve performance.

7. Decrease your real-time view's resolution.
You may set the real-time resolution from within the Project window's Image tab. You may also drag a corner on the real-time window.

Let me know if this helps your slowing issue.


Referencing your Ticket ID#:9442

Thanks,

Justin Adams
Support manager
Luxion Inc
15143 Woodlawn Ave
Tustin, CA 92780
Phone: (949) 274-8871
Fax: (949) 266-9523
http://www.keyshot.com
 


Login or Signup to post a comment