Start a new topic
Answered

Pausing Render Bug

Windows 10

GPU mode


After updating to version 9.3 yesterday it looks like render pause no longer functions properly. 


When I click on the pause button, the huge "PAUSED" text appears in the middle of the screen, but the samples keep climbing in the bottom right corner and the CPU/GPU load in Task Manager stays the same.


Best Answer
Hello Derek,

Can you go to the 'edit' tab in the top toolbar, then 'preferences'->'general'?
Here you will see 'Pause Real-time Render after', followed by some options.
What number is shown next to 'samples?
  • If you change the number of samples to '5' and pause the real-time view, does it stop?
  • If it doesn't stop right away, give it a moment
  • If it does stop, how many samples are collected when it stops?
If it stops at 80 samples, this is an issue we have recently discovered with the platform. In GPU rendering mode, real-time samples are collected in multiples of 16. The sample count will finally stop once it believes the correct number of samples has been collected.
CPU rendering does not experience this issue.

​We are investigating this issue now and hope to have it resolved as soon as possible. 
Let me know if this is the case.



 


Referencing your Ticket ID#:6967

 

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

Answer
Hello Derek,

Can you go to the 'edit' tab in the top toolbar, then 'preferences'->'general'?
Here you will see 'Pause Real-time Render after', followed by some options.
What number is shown next to 'samples?
  • If you change the number of samples to '5' and pause the real-time view, does it stop?
  • If it doesn't stop right away, give it a moment
  • If it does stop, how many samples are collected when it stops?
If it stops at 80 samples, this is an issue we have recently discovered with the platform. In GPU rendering mode, real-time samples are collected in multiples of 16. The sample count will finally stop once it believes the correct number of samples has been collected.
CPU rendering does not experience this issue.

​We are investigating this issue now and hope to have it resolved as soon as possible. 
Let me know if this is the case.



 


Referencing your Ticket ID#:6967

 

Med Venlig Hilsen / Best Regards,

Erik Williams
Customer Support Specialist

I set the "Pause Real-time Render after" to the minimum amount of 16 samples. With GPU Mode turned on, real time preview never stops. With CPU Mode turned on it does indeed stop at 16 samples.


This exactly mirrors the problem in render output: GPU Mode never responds to pausing, but CPU Mode does.

Login or Signup to post a comment